The Virus Lounge's todo-list


Profpatsch

At //nix/emptyDerivation/emptyDerivation.nix:19:

TODO(Profpatsch): can we get system from tvl?

At //nix/getBins/default.nix:30:

TODO(Profpatsch): typecheck

At //nix/runExecline/runExecline.nix:76:

TODO(Profpatsch): what about cross?

At //nix/runExecline/runExecline.nix:114:

TODO(Profpatsch): depending on the use-case, -S0 might not be enough

At //nix/runTestsuite/default.nix:109:

TODO(Profpatsch): pretty printing of results


grfn

At //lisp/klatre/klatre.lisp:79:

TODO(grfn): Allow passing offset

At //third_party/default.nix:164:

TODO(grfn): Move back to unstable once it is fixed

At //third_party/lisp/ironclad.nix:26:

TODO(grfn): Figure out how to get this compiling with the assembly

At //third_party/nix/src/libstore/build.cc:4249:

TODO(grfn): Do we need this?

At //third_party/nix/src/libstore/crypto.cc:34:

TODO(grfn): replace this with StatusOr

At //third_party/nix/src/libstore/crypto.cc:99:

TODO(grfn): replace this with StatusOr

At //third_party/nix/src/libstore/derivations.hh:21:

TODO(grfn): make these two fields a Hash

At //third_party/nix/src/libstore/rpc-store.cc:81:

TODO(grfn): Obviously this should go away and be replaced by StatusOr... but

At //third_party/nix/src/libstore/rpc-store.cc:296:

TODO(grfn): what is fixed?

At //third_party/nix/src/libstore/rpc-store.cc:540:

TODO(grfn): Make this a function that we call from main rather than... this

At //third_party/nix/src/libstore/rpc-store.hh:12:

TODO(grfn): Currently, since the RPCStore is only used for the connection to

At //third_party/nix/src/libutil/hash.hh:16:

TODO(grfn): Replace this with the hash type enum from the daemon proto so we

At //third_party/nix/src/libutil/util.cc:558:

TODO(grfn): Remove in favor of std::filesystem::create_directories

At //third_party/nix/src/nix-build/nix-build.cc:275:

TODO(grfn): Generate a syntax tree here, not a string

At //third_party/nix/src/nix-daemon/nix-daemon-proto.cc:53:

TODO(grfn): Make Source::read return a StatusOr and get rid of this

At //third_party/nix/src/nix-daemon/nix-daemon-proto.cc:70:

TODO(grfn): Make this some sort of pipe so we don't have to store data in

At //third_party/nix/src/nix-daemon/nix-daemon-proto.cc:188:

TODO(grfn): Don't store the full data in memory, instead just

At //third_party/nix/src/nix-daemon/nix-daemon-proto.cc:330:

TODO(grfn): If mode is repair and not trusted, we need to return an

At //third_party/nix/src/nix-daemon/nix-daemon-proto.cc:731:

TODO(grfn): Switch to concrete size type

At //third_party/nix/src/nix-daemon/nix-daemon.cc:34:

TODO(grfn): There has to be a better way to do this - this was ported

At //third_party/nix/src/nix-daemon/nix-daemon.cc:193:

TODO(grfn): Need to launch a server on stdin here - upstream calls

At //third_party/nix/src/proto/worker.proto:36:

TODO(grfn): This should not actually take a StorePath, as it's not a

At //third_party/nix/src/proto/worker.proto:322:

TODO(grfn): Remove double-negative

At //third_party/nix/src/tests/attr-set.cc:31:

TODO(grfn): These arbitrary implementations should be pulled out to a util

At //users/glittershark/xanthous/default.nix:8:

TODO(grfn): Get this passing (see https://buildkite.com/tvl/depot/builds/3055)

At //web/panettone/src/authentication.lisp:71:

TODO(grfn): make this configurable


lukegb

At //fun/clbot/gerrit/gerritevents/types.go:178:

TODO(lukegb): data


riking

At //third_party/bufbuild/default.nix:19:

TODO(riking): postinstall produce shell completions for bash, fish, zsh

At //third_party/nix/src/libstore/crypto.cc:14:

TODO(riking): convert to string_view to reduce allocations

At //third_party/nix/src/libutil/hash.cc:225:

TODO(riking): change ht to an optional

At //tools/tvlc/tvlc-new:63:

TODO(riking): deduce


tazjin

At //fun/aoc2019/default.nix:16:

TODO(tazjin): move writeElispBin to depot.nix

At //fun/paroxysm/src/main.rs:1:

TODO(tazjin): Upgrade to a Diesel version with public derive

At //lisp/dns/client.lisp:38:

TODO(tazjin): Figure out why 'want-stream' doesn't work

At //lisp/dns/message.lisp:372:

TODO(tazjin): Deal with multiple strings in single RRDATA

At //nix/buildLisp/default.nix:96:

TODO(tazjin): Compression is currently unsupported because the

At //ops/nixos/default.nix:7:

TODO(tazjin): Find a more elegant solution for the whole module

At //ops/nixos/default.nix:54:

TODO(tazjin): Refactor the whole systems setup, it's a bit

At //ops/nixos/monorepo-gerrit.nix:87:

TODO(tazjin): Assuming this is what we'll be doing ...

At //ops/nixos/tvl-slapd/default.nix:3:

TODO(tazjin): Configure ldaps://

At //ops/nixos/www/base.nix:18:

TODO(tazjin): Find a link to the upstream issue and see if

At //overrides/default.nix:6:

TODO(tazjin): remove this

At //third_party/nix/clangd.nix:28:

TODO(tazjin): Configurable commands directory?

At //third_party/nix/config.h.in:13:

TODO(tazjin): generate

At //third_party/nix/config.h.in:16:

TODO(tazjin): some of these values are nonsensical for Nix

At //third_party/nix/default.nix:50:

TODO(tazjin): Some of these might only be required for native inputs

At //third_party/nix/default.nix:161:

TODO(tazjin): integration test setup?

At //third_party/nix/default.nix:162:

TODO(tazjin): docs generation?

At //third_party/nix/src/libexpr/attr-set.cc:82:

TODO(tazjin): A lot of 0-capacity Bindings are allocated.

At //third_party/nix/src/libexpr/attr-set.hh:10:

TODO(tazjin): ::expr

At //third_party/nix/src/libexpr/attr-set.hh:18:

TODO(tazjin): Who owns this?

At //third_party/nix/src/libexpr/attr-set.hh:19:

TODO(tazjin): Who owns this?

At //third_party/nix/src/libexpr/eval.cc:783:

TODO(tazjin): insert range

At //third_party/nix/src/libexpr/eval.cc:1748:

TODO(tazjin): what is this? commented out because .dump() is gone.

At //third_party/nix/src/libexpr/nixexpr.hh:11:

TODO(tazjin): audit this include

At //third_party/nix/src/libexpr/nixexpr.hh:32:

TODO(tazjin): remove this - empty pos is never useful

At //third_party/nix/src/libexpr/parser.hh:4:

TODO(tazjin): Audit these includes, they were in parser.y

At //third_party/nix/src/libexpr/parser.hh:46:

TODO(tazjin): move dupAttr to anonymous namespace

At //third_party/nix/src/libexpr/primops.cc:1291:

TODO(tazjin): this line used to construct the symbol again:

At //third_party/nix/src/libexpr/primops.cc:1384:

TODO(tazjin): figure out what the above comment means

At //third_party/nix/src/libexpr/primops/context.cc:151:

TODO(tazjin): get rid of this

At //third_party/nix/src/libexpr/symbol-table.hh:6:

TODO(tazjin): ::expr

At //third_party/nix/src/libexpr/symbol-table.hh:8:

TODO(tazjin): Replace with a simpler struct, or get rid of.

At //third_party/nix/src/libexpr/symbol-table.hh:38:

TODO(tazjin): Figure out which things use this. AttrSets, ...?

At //third_party/nix/src/libexpr/value.hh:43:

TODO(tazjin): Really, these types need some serious refactoring.

At //third_party/nix/src/libexpr/value.hh:93:

TODO(tazjin): std::variant

At //third_party/nix/src/libexpr/value.hh:101:

TODO(tazjin): "app"?

At //third_party/nix/src/libmain/shared.cc:258:

TODO(tazjin): figure out what the fuck this is

At //third_party/nix/src/libstore/build.cc:146:

TODO(tazjin): Rename all build_log instances to log_sink.

At //third_party/nix/src/libstore/build.cc:696:

TODO(tazjin): what?

At //third_party/nix/src/libstore/build.cc:3787:

TODO(tazjin): What ... what does this function ... do?

At //third_party/nix/src/libstore/derivations.hh:42:

TODO(tazjin): Determine whether this actually needs to be ordered.

At //third_party/nix/src/libstore/download.cc:262:

TODO(tazjin): Add an Abseil flag for this

At //third_party/nix/src/libstore/gc.cc:739:

TODO(tazjin): absl::StrFormat %.2f

At //third_party/nix/src/libstore/globals.cc:62:

TODO(tazjin): still?

At //third_party/nix/src/libstore/local-store.hh:100:

TODO(tazjin): remove this when we've got gRPC

At //third_party/nix/src/libstore/machines.cc:87:

TODO(tazjin): what???

At //third_party/nix/src/libstore/remote-store.cc:169:

TODO(tazjin): are these types of things supposed to be DEBUG?

At //third_party/nix/src/libstore/rpc-store.cc:364:

TODO(tazjin): Include .path()?

At //third_party/nix/src/libstore/ssh.cc:77:

TODO(tazjin): Abseil verbosity flag

At //third_party/nix/src/libstore/store-api.hh:25:

TODO(tazjin): Get rid of this and do *something* with those logs.

At //third_party/nix/src/libstore/store-api.hh:470:

TODO(tazjin): Thread std::ostream through here, too.

At //third_party/nix/src/libutil/config.cc:104:

TODO(tazjin): absl::string_view after path functions are fixed.

At //third_party/nix/src/libutil/ref.hh:12:

TODO(tazjin): rename to brainworm_ref or something

At //third_party/nix/src/libutil/util.cc:324:

TODO(tazjin): use stdlib functions for this stuff

At //third_party/nix/src/nix-daemon/nix-daemon.cc:17:

TODO(tazjin): can this be removed?

At //third_party/nix/src/nix-store/nix-store.cc:33:

TODO(tazjin): clang-tidy's performance lints don't like this, but

At //third_party/nix/src/proto/worker.proto:117:

TODO(tazjin): still needed?

At //third_party/nix/src/proto/worker.proto:214:

TODO(tazjin): what is this? "obsolete" comment?

At //third_party/nix/src/proto/worker.proto:253:

TODO(tazjin): Maybe this should be bool, unclear.

At //third_party/nix/src/proto/worker.proto:254:

TODO(tazjin): Difference from max_build_jobs?

At //third_party/nix/src/proto/worker.proto:256:

TODO(tazjin): better name?

At //third_party/notmuch/default.nix:7:

TODO(tazjin): Fix the build and re-enable CI.

At //tools/cheddar/src/main.rs:89:

TODO(tazjin): memoize this lookup

At //tools/cheddar/src/main.rs:195:

TODO(tazjin): hrmm

At //tools/emacs-pkgs/nix-util/nix-util.el:19:

TODO(tazjin): support different branches

At //tools/emacs-pkgs/nix-util/nix-util.el:81:

TODO(tazjin): use

At //tools/emacs-pkgs/notable/notable.el:36:

TODO(tazjin): Use whatever the XDG state dir thing is for these by

At //tools/emacs-pkgs/notable/notable.el:187:

TODO(tazjin): `imenu' functions?

At //users/tazjin/blog/default.nix:55:

TODO(tazjin): 301 once this works

At //users/tazjin/blog/posts/emacs-is-underrated.md:8:

TODO(tazjin): Restructure sections: Intro -> Introspectability (and

At //users/tazjin/blog/posts/emacs-is-underrated.md:13:

TODO(tazjin): Highlight more that it's not about editing: People can

At //users/tazjin/blog/posts/emacs-is-underrated.md:16:

TODO(tazjin): Note that there's value in trying Emacs even if people

At //users/tazjin/blog/posts/emacs-is-underrated.md:206:

TODO(tazjin): Figure out what people should take away from this post.

At //users/tazjin/emacs/config/functions.el:300:

TODO(tazjin): Inspect status, which looks different in practice

At //users/tazjin/emacs/config/init.el:9:

TODO(tazjin): Figure out what's up with vc.

At //users/tazjin/emacs/config/look-and-feel.el:74:

TODO(tazjin): lets not do this particular thing while I

At //users/tazjin/homepage/feed.nix:17:

TODO(tazjin): this should be distinct from published

At //users/tazjin/homepage/feed.nix:44:

TODO(tazjin): Take the most recently updated entry time instead.

At //users/tazjin/nixos/camden/default.nix:21:

TODO(tazjin): Remove this once the new ACME module works.

At //users/tazjin/nixos/camden/default.nix:43:

TODO(tazjin): Configure LUKS unlocking via SSH instead.

At //users/tazjin/nixos/default.nix:1:

TODO(tazjin): Generalise this and move to //ops/nixos

At //users/tazjin/nixos/frog/default.nix:182:

TODO(tazjin): TZ?

At //users/tazjin/rlox/src/scanner.rs:59:

TODO(tazjin): Uhh?

At //users/tazjin/rlox/src/scanner.rs:80:

TODO(tazjin): Due to utf8-safety, this is a bit annoying.